Dein Warenkorb ist leer

Category Fusion für JTL-Shop 5 & Store-Änderungen

Mit Category Fusion 2.0.0 veröffentlichen wir unsere erste Pluginversion für JTL-Shop 5. Im gleichen Zuge haben wir unseren Store an einigen Stellen erweitert.

Unseren Plan für Dropper und JTL-Shop 5 haben wir euch im letzten Beitrag vorgestellt. Nun häufen sich Fragen nach der Kompatibilität anderer Plugins mit JTL-Shop 5.

Vorab noch einmal grundlegend: unsere Plugins für JTL-Shop 4 (wie vermutlich 99% aller Plugins für JTL-Shops) funktionieren nicht ohne weitere Anpassungen in JTL-Shop 5. Es wird von uns daher neue, separate Pluginversionen geben müssen.

Da sich auch die Versionierung der Plugins mit JTL-Shop 5 ändert, starten wir auch hier neu. Den Anfang macht Category Fusion Version 2.0.0! Funktional ändert sich in dieser Version nichts im Vergleich zur Vorgängerversion 107 für JTL-Shop 4.

Neue Versionsvielfalt im Store

Neben der neuen Version wird es weiterhin das Installationspaket für das JTL-Shop 4 Plugin geben. Um zukünftig die Übersicht zu wahren, haben wir den Downloaddialog auf unseren Pluginseiten etwas angepasst und erweitert.

Neben den aktuellen Versionen erhaltet ihr nun auch Zugriff auf ältere Versionen der Plugins . Dies gilt auch für Plugins, für die es bisher noch keine JTL-Shop 5 Versionen gibt.

Update von Shop 4 auf Shop 5 möglich?

Ein bequemes One-Click-Update von Category Fusion 107 auf 2.0.0 nach einem Shopupdate ist leider nicht möglich .

Solltet ihr Category Fusion bereits in einem JTL-Shop 4 einsetzen und im JTL-Shop 5 weiterverwenden, so empfiehlt sich folgendes Vorgehen.

Vor dem Shopupdate

  • Category Fusion auf die aktuellste Version für JTL-Shop 4 aktualisieren (aktuelle Version: 107)
  • Die Plugineinstellungen via Screenshot oder Textdatei sichern
  • Zur Sicherheit ein Backup des Ordners includes/plugins/kk_categoryfusion/ erstellen

Nach dem Shopupdate

  • Das alte Plugin (Version 107 wird als 1.7.0 angezeigt) in der Pluginverwaltung deinstallieren und den Ordner includes/plugins/kk_categoryfusion/ dabei löschen (Option "Ja, alle Plugin Dateien löschen.")
  • Die neue Version für Shop 5 herunterladen (aktuelle Version: 2.0.0) und via Pluginverwaltung installieren
  • Die vorherigen Einstellungen manuell wiederherstellen

Und der JTL Extension Store?

Der JTL Extension Store hat den JTL Store nunmehr abgelöst. Shopbetreiber sollen über den neuen Marktplatz Lizenzen für Plugins und Templates von Drittanbietern direkt erwerben.

Leider ist eine bloße Listung von Plugins nicht vorgesehen, weshalb unsere Plugins bisher noch nicht im Extension Store zu finden sind. Das wird dann wieder der Fall sein, wenn einige technische Hürden (Lizenzierung, Automatisierung) rund um die Lizenzierung und Kaufabwicklung der Erweiterungen überwunden sind.